AdvanceOnline

What You Need to Begin

We like you. That's why AdvanceOnline makes it so simple for you to learn and stay safe. We do our best to accommodate many types of learners on many types of devices. Please see the required and recommended system configurations further down the page.

Next, you'll see your current system configuration. If this is the device from which you're going to take courses you can easily see if you meet the requirements.

Your System

Generic crawler

Generic crawler 2

Unknown

Unknown

warning Your Flash Player plug-in is not supported. To use our courses, you must have Flash Player 10+ plug-in. Please upgrade to Flash Player 10 or higher.

Courses Marked Mobile-Friendly Computer Tablet

Required

Internet Access. (Hey, you're 1/3 of the way there already!)

The most recent version of one of the following Internet browser programs or apps:

The following free browser add-ons or apps:

Recommended

That's it! No fancy hoops.

Other Courses

Video Course Requirements

Check the Learn More link in the catalog to see if your course has video.

Courses without the Mobile-Friendly Designation

Required for courses not listed as Mobile-Friendly. Click the Learn More link in the catalog to check.

See, that was easy. We told you we like you! In fact, you've always been our favorite and we're going to make sure you like us too. If you need help let us know.

1999 - 2018 © AdvanceOnline Solutions, Inc. All rights reserved. System Requirements Terms of Use Privacy Statement Site Map